various info‘s I kept on old .txt files about my edgerouter light running openbsd

Upgrade procedure (very vague, do read the official upgrade steps!)

    mount /dev/sd0i /mnt  
    cd /mnt  
    wget https://cdn.openbsd.org/pub/OpenBSD/6.7/octeon/bsd.rd  
    wget https://cdn.openbsd.org/pub/OpenBSD/6.7/octeon/SHA256.sig  
    signify -Cp /etc/signify/openbsd-67-base.pub -x SHA256.sig bsd.rd  

Then don‘t forget to attach the serial interface screen /dev/ttyUSB0 115200 and reboot the device and do the upgrade :) good luck.


newest try. upgrading my router to openbsd 6.8

ok, so that I hopefully don’t get into a situation without internet for some time (and because I’m skipping 6.7) I won’t upgrade but instead install fresh on a new usb stick, saving the old one with 6.6, to use if anything fails.

So first I need to get the data out, so I can recreate all the changes I did to /etc (on the edgerouter):

scp -r /etc/ username@nas:/backupfolder

then I need to prepare a web server or nfs share on my nas to install from: wget -r -nH --cut-dirs=4 -np https://cdn.openbsd.org/pub/OpenBSD/6.8/octeon/

And I need to get the bsd.rd file to the topfolder of the tftp server.

Now it should be as easy as: Shutdown Plug in a new usb drive start up a serial console screen /dev/ttyUSB0 115200 press ctrl-c to interrupt the booting set the ipaddress of the router: setenv ipaddr <static ip> set the tftp server ip address: setenv serverip <server ip> load the installer: tftpboot 0 bsd.rd and finally boot: bootoctlinux

Then there’s the installer business (you get a shell with ! at any prompt) which is pretty straight-forward

and then in the U-Boot as per INSTALL.octeon

setenv bootcmd 'fatload usb 0 ${loadaddr} boot; bootoctlinux rootdev=sd0 numcores=2'
setenv bootdelay 5
saveenv

and reboot :)

there finished.

Well ok, let’s get those errata patched in while we’re at it:

as detailed in this nice post we need to load the src and sys tar.gz files check and extract them before we can patch so:

	cd /usr/src/
	ftp ftp://ftp.fau.de/pub/OpenBSD/6.8/src.tar.gz
	ftp ftp://ftp.fau.de/pub/OpenBSD/6.8/sys.tar.gz
	ftp ftp://ftp.fau.de/pub/OpenBSD/6.8/SHA256.sig
	signify -C -p /etc/signify/openbsd-68-base.pub -x SHA256.sig src.tar.gz 
	signify -C -p /etc/signify/openbsd-68-base.pub -x SHA256.sig sys.tar.gz
	tar zxf src.tar.gz
	tar zxf sys.tar.gz
	rm SHA256.sig *.tar.gz

then you can grab the errata and do as you’re told in there.

all this takes forever on this device. hmm, shame there’s no syspatch available, but well, that’s what you get for using non-standard hardware. And it is part of the reason, one uses non-standard hardware, it’s as hard for everyone else, as for you to find precompiled software for it :) :P